Eclipse no macOS Catalina

Precisei instalar o Eclipse IDE no macOS Catalina. Entretanto, na hora que tento rodar o aplicativo, nos exibe o seguinte erro abaixo:

Acontece que o JDK que nos é proposto possuem dois problemas:

  1. Bastante antigo, já que é o Java 1.6;
  2. O Java da Oracle agora é pago caso esteja usando-o para fins comerciais.

Para contornar esse problema, temos o Liberica JDK, que é uma compilação do OpenJDK bem próxima do JDK da Oracle (possui o JavaFX, por exemplo).

Entretanto precisa ser instalado a versão do JDK ou com o DMG ou o PKG. Quem já conhece o Mac sabe o quanto é difícil atualizar os aplicativos instalados dessa maneira.

Em nosso auxílio temos o Homebrew. Instale-o seguindo as instruções do site deles:

Uma vez instalado este utilitário, precisamos executar os seguintes comandos no Terminal:

brew tap bell-sw/liberica
brew cask install liberica-jdk11

Elegi a versão 11 do JDK pois é a última com LTS (até o presente momento).

Mas nada impede que você tenha instalado em outro diretório o JDK para uma versão como a 8, por exemplo.

Após instalado o OpenJDK 11, tente novamente abrir o Eclipse IDE.

Observação: Não utilze o SDKMAN! Somente funcionou desta forma com o Homebrew.

Referências:

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *

Esse site utiliza o Akismet para reduzir spam. Aprenda como seus dados de comentários são processados.

Rolar para o topo